<!doctype html><html lang="fr">
<head>
    <title>Fichier de configuration PHPStan typique pour un projet Symfony</title>
        <meta charset="utf-8">
    <meta content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0" name="viewport" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
    <meta name="google-site-verification" content="vPL1A7DrKFKvN6Wg064XXLjMAnyC_rnlQ_dN9Km8lCw" />
    <link rel="preconnect" href="https://cdn.jsdelivr.net" />
    <link rel="preconnect" href="https://fonts.googleapis.com" />
    <link rel="preconnect" href="https://www.googletagmanager.com" />
            <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Roboto:300,400,500,700|Roboto+Slab:400,700|Material+Icons" />
        <link rel="stylesheet" href="/vendor/material/css/material-kit.css?2.8.0">
        <link rel="stylesheet" type="text/css" href="/vendor/fontawesome/css/all.min.css?2.8.0" />
        <link rel="stylesheet" href="/build/app.f9c480cb.css?2.8.0">
        <link rel="apple-touch-icon" sizes="57x57" href="/apple-icon-57x57.png?2.8.0" />
    <link rel="apple-touch-icon" sizes="60x60" href="/apple-icon-60x60.png?2.8.0" />
    <link rel="apple-touch-icon" sizes="72x72" href="/apple-icon-72x72.png?2.8.0" />
    <link rel="apple-touch-icon" sizes="76x76" href="/apple-icon-76x76.png?2.8.0" />
    <link rel="apple-touch-icon" sizes="114x114" href="/apple-icon-114x114.png?2.8.0" />
    <link rel="apple-touch-icon" sizes="120x120" href="/apple-icon-120x120.png?2.8.0" />
    <link rel="apple-touch-icon" sizes="144x144" href="/apple-icon-144x144.png?2.8.0" />
    <link rel="apple-touch-icon" sizes="152x152" href="/apple-icon-152x152.png?2.8.0" />
    <link rel="apple-touch-icon" sizes="180x180" href="/apple-icon-180x180.png?2.8.0" />
    <link rel="icon" type="image/png" sizes="192x192"  href="/android-icon-192x192.png?2.8.0" />
    <link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png?2.8.0" />
    <link rel="icon" type="image/png" sizes="96x96" href="/favicon-96x96.png?2.8.0" />
    <link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png?2.8.0" />
    <link rel="manifest" href="/manifest.json">
            <link rel="canonical" href="https://www.strangebuzz.com/fr/snippets/fichier-de-configuration-phpstan-typique-pour-un-projet-symfony" title="canonical" />
            <link rel="alternate" type="application/atom+xml" title="Le blog Strangebuzz PHP / Symfony : plus de code, moins de blabla." href="https://feeds.feedburner.com/strangebuzz/fr" />
        <meta name="msapplication-TileColor" content="#ffffff">
    <meta name="msapplication-TileImage" content="/ms-icon-144x144.png">
    <meta name="theme-color" content="#ffffff">
    <meta name="description" content="Voici un fichier de configuration PHPStan typique pour un projet Symfony. J&#039;ai ajouté des liens vers la documentation afin de voir la signification de chaq" />
        <meta property="og:type" content="website" />
    <meta property="og:url" content="https://www.strangebuzz.com/fr/snippets/fichier-de-configuration-phpstan-typique-pour-un-projet-symfony" />
    <meta property="og:title" content="Fichier de configuration PHPStan typique pour un projet Symfony" />
    <meta property="og:description" content="Voici un fichier de configuration PHPStan typique pour un projet Symfony. J&#039;ai ajouté des liens vers la documentation afin de voir la signification de chaq" />
        <meta property="og:site_name" content="Strangebuzz" />
    <meta property="og:locale" content="fr" />
    <meta property="og:locale:alternate" content="en" />
    <meta property="og:image" content="https://www.strangebuzz.com/img/strangebuzz_1024.jpg" />
    <meta name="twitter:card" content="summary" />
    <meta name="twitter:site" content="@C0il" />
    <meta name="twitter:creator" content="@C0il" />
    <meta name="twitter:url" content="https://www.strangebuzz.com/fr/snippets/fichier-de-configuration-phpstan-typique-pour-un-projet-symfony" />
    <meta name="twitter:title" content="Fichier de configuration PHPStan typique pour un projet Symfony" />
    <meta name="twitter:description" content="Voici un fichier de configuration PHPStan typique pour un projet Symfony. J&#039;ai ajouté des liens vers la documentation afin de voir la signification de chaq" />
        <meta name="twitter:image" content="https://www.strangebuzz.com/img/strangebuzz_1024.jpg" />
</head>

<body lang="fr" dir="ltr" id="body-strangebuzz">
    <div id="vue">
        <noscript>Mettez à jour votre navigateur bordel aqueu !</noscript>
        <a id="top"></a>

        <form action="/fr/recherche" method="get">
            <nav class="navbar fixed-top navbar-expand-lg bg-dark">
                <div class="container">
                    <a class="navbar-brand" href="/fr"><b>🐝 Strangebuzz</b></a>
                    <button class="navbar-toggler" type="button" data-toggle="collapse" data-target="#navbarNav" aria-controls="navbarNav" aria-expanded="false" aria-label="Toggle navigation">
                        <span class="navbar-toggler-icon"></span>
                    </button>

                                        <div class="collapse navbar-collapse" id="navbarNav">
                        <ul class="navbar-nav">
                            <li class="nav-item">
                                <a class="nav-link" href="/fr/blog/">Blog</a>
                            </li>

                            <li class="nav-item active">
                                <a class="nav-link" href="/fr/snippets/">Snippets</a>
                            </li>

                            <li class="dropdown nav-item">
                                <a class="nav-link dropdown-toggle" href="#" id="navbarDropdown" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
                                    Outils
                                </a>
                                <div class="dropdown-menu" aria-labelledby="navbarDropdown">
                                    <a class="dropdown-item" href="/fr/outils/">Outils</a>
                                    <a class="dropdown-item" href="/fr/outils/quelle-est-mon-ip">Quelle est mon ip ?</a>
                                    <a class="dropdown-item" href="/fr/outils/est-ce-que-mon-mot-de-passe-a-ete-compromis">Est-ce que mon mot de passe a été compromis ?</a>
                                    <a class="dropdown-item" href="/fr/outils/emojis">Mes emojis</a>
                                    <a class="dropdown-item" href="/fr/outils/statistiques-de-fichier-i18n">Statistiques de fichier i18n</a>
                                </div>
                            </li>

                            <li class="nav-item dropdown">
                                <a class="nav-link dropdown-toggle" href="#" id="navbarDropdown" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
                                    Divers
                                </a>
                                <div class="dropdown-menu" aria-labelledby="navbarDropdown">
                                    <a class="dropdown-item" href="/fr/stack">Stack technique du projet</a>
                                    <a class="dropdown-item" href="/fr/rgpd">RGPD</a>
                                    <a class="dropdown-item" href="/fr/a-propos">À propos</a>
                                                                    </div>
                            </li>

                            <li class="nav-item">
                                <a class="nav-link" href="/fr" title="Accéder à la version française">🇫🇷</a>
                            </li>

                            <li class="nav-item">
                                <a class="nav-link" href="/en" title="Accéder à la version anglaise">🇬🇧</a>
                            </li>

                            <li class="nav-item">
                                <autocomplete
    ref="autocomplete"
    aria-describedby="qHelp"
    url="/fr/suggerer"     anchor="text"     label="text"
    :on-should-render-child="autocompleteRenderChild"
    :required="true"
    id="post-q"
    name="q"
    :classes="{ wrapper: 'form-wrapper', input: 'form-control', list: 'data-list', item: 'data-list-item' }"
    placeholder="Rechercher un truc ?"
    init-value=""
    :options="[]"
    :min="1"
    :encode-params="true"
>
</autocomplete>
                            </li>
                            <li class="nav-item">
                               <button title="Lancer la recherche ! 🔎" type="submit" class="btn btn-primary btn-sm"><i class="fab fa-searchengin"></i></button>
                            </li>
                        </ul>
                    </div>
                </div>
            </nav>
        </form>

        <div class="page-header header-filter header-small" data-parallax="true" style="background-image: url(/img/strangebuzz2.png);">
            <div class="container">
                <div class="row">
                    <div class="col-md-8 ml-auto mr-auto text-center">
                                                    <p class="title h1">Symfony / PHP / JavaScript / Vue.js / Docker / Devops...</p>
                            <p class="h4"><i class="fal fa-code"></i> Moins de blabla... plus de code. <i class="fal fa-code"></i></p>
                                            </div>
                </div>
            </div>
        </div>

        <div class="main main-raised">
            <div class="container">
                <div class="section section-text">
                    <div id="row-breadcrumbs" class="row">
                            <nav aria-label="breadcrumb" role="navigation">
        <ol id="wo-breadcrumbs" class="breadcrumb hidden-xs" itemscope itemtype="https://schema.org/BreadcrumbList">
                            <li class="breadcrumb-item" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
                                        <a href="/fr" itemprop="item">
                                            <span itemprop="name">Accueil</span>
                                        </a>
                                        <meta itemprop="position" content="1" />

                                    </li>
                            <li class="breadcrumb-item" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
                                        <a href="/fr/snippets/" itemprop="item">
                                            <span itemprop="name">Snippets</span>
                                        </a>
                                        <meta itemprop="position" content="2" />

                                    </li>
                            <li class="breadcrumb-item" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
                                            <span itemprop="name">Fichier de configuration PHPStan typique pour un projet Symfony</span>
                                        <meta itemprop="position" content="3" />

                                    </li>
                    </ol>
    </nav>
                     </div>

                    <div id="vue" class="row">
                            <div class="card">
        <div class="card-header">
            <h1 class="h2">
                                Fichier de configuration PHPStan typique pour un projet Symfony <i class="fad fa-check-circle"></i>                
            </h1>
        </div>

        <div class="card-body" ref="article119">
            <p class="card-subtitle mb-2 text-muted h6">
    Publié le 11/11/2020 &bull;
    Mis à jour le 20/11/2020
</p>

            

            <div v-show="showLangSwitcher" style="display:none">
        <br/>
        <div class="card card-nav-tabs text-center">
            <div class="card-header card-header-primary">
                <p class="h4">English language detected! 🇬🇧</p>
            </div>

            <div class="card-body">
                <h4 class="card-title">&nbsp; We noticed that your browser is using English. Do you want to read this post in this language?
</h4>
                <a href="../../en/snippets/typical-phpstan-configuration-file-for-a-symfony-project" class="btn btn-primary">Read the english version 🇬🇧</a>
                <a v-on:click.prevent="disableLangSwitcher" class="btn" href="#">Close</a>
            </div>
        </div>
    </div>

                            <p class="h4 justify">Voici un fichier de configuration PHPStan typique pour un projet Symfony. J'ai ajouté des liens vers la documentation afin de voir la signification de chaque paramètre. Il y a quelques plugins à installer. Celui relatif à Symfony est essentiel puisqu'il permet à PHPStan d'avoir accès et de pouvoir inspecter le conteneur de dépendances. Les autres ajoutent des règles supplémentaires. Bien sûr, vous êtes libres de les installer ou pas. Si vous commencer à utiliser PHPStan sur un ancien projet, il va surement détecter de nombreux problèmes. Dans ce cas, mon conseil est de commencer au niveau 0 puis de passer au suivant une fois que toutes les erreurs ont été corrigées. Prenez ça comme un jeu ! 😀
</p>
            
            <hr/>

                        
                            <pre class="yaml"><code># configuration/phpstan.neon
includes:
    # require phpstan/extension-installer to avoid inlcuding these lines
    #- vendor/ekino/phpstan-banned-code/extension.neon     # https://github.com/ekino/phpstan-banned-code
    #- vendor/phpstan/phpstan-symfony/extension.neon       # https://github.com/phpstan/phpstan-symfony
    #- vendor/phpstan/phpstan-deprecation-rules/rules.neon # https://github.com/phpstan/phpstan-deprecation-rules
    #- vendor/phpstan/phpstan-strict-rules/rules.neon      # https://github.com/phpstan/phpstan-strict-rules
    #- vendor/phpstan/phpstan/phpstan-doctrine             # https://github.com/phpstan/phpstan-doctrine

rules:
    - App\PHPStan\ControllerIsFinalRule
    - App\PHPStan\ControllerExtendsSymfonyRule
    #- App\PHPStan\NoNewinControllerRule

parameters:
    # https://phpstan.org/config-reference#rule-level
    level: max

    # https://phpstan.org/config-reference#analysed-files
    # Note that I have put my configuraiton file in the &quot;./configuration&quot; directory
    # if you have yours at the root of your project remove the &quot;../&quot;
    paths:
        - ../config
        - ../src
        - ../tests
        - ../public

    # https://github.com/phpstan/phpstan-symfony#configuration
    # Specific configuration for the Sumfony plugin
    symfony:
        # I use the prod env because I have false positive regarding the tests which
        # are executed in the test environment.
        container_xml_path: ../var/cache/prod/App_KernelProdDebugContainer.xml

    # https://phpstan.org/config-reference#vague-typehints
    checkMissingIterableValueType: true
    checkGenericClassInNonGenericObjectType: true # this parameter is activated at level 6

    # It&#039;s a special &quot;dev&quot; project, I have to ignore the following warnings because
    # the use of this functions is intended.
    # @see https://phpstan.org/user-guide/ignoring-errors
    ignoreErrors:
        - &#039;#Should not use node with type &quot;Expr_Exit&quot;, please change the code.#&#039; # warnings for &quot;die()&quot;
        - &#039;#Should not use node with type &quot;Stmt_Echo&quot;, please change the code.#&#039; # warnings for &quot;echo()&quot;
        - &#039;#Should not use function &quot;print_r&quot;, please change the code.#&#039;         # warnings for &quot;print_r()&quot;
        - &#039;#Should not use function &quot;var_dump&quot;, please change the code.#&#039;        # warnings for &quot;var_dump()&quot;
        - &#039;#Should not use function &quot;phpinfo&quot;, please change the code.#&#039;         # warnings for &quot;phpinfo()&quot;
        - &#039;#Variable method call on#&#039;                                            # dev blog!

    # I don&#039;t use the Symfony PHPUnit bridge in this project, but if you do, you
    # probably will have to add the following bootstrap file:
    #bootstrapFiles:
        #- %rootDir%/../../../vendor/bin/.phpunit/phpunit/vendor/autoload.php
</code></pre>
            
            
            <p class="card-text text-center">
                



        <a target="_blank" href="https://stackoverflow.com/q/61418252/633864" class="btn btn-warning card-link text-center"><i class="fab fa-stack-overflow"></i> &nbsp;Plus sur Stackoverflow</a>


        <a target="_blank" href="https://phpstan.org/user-guide/getting-started" alt="RTFM" class="btn btn-primary card-link text-center"><i class="fa fa-external-link"></i> &nbsp; Lire la doc</a>

        <a target="_blank" href="https://github.com/phpstan/phpstan-symfony" class="btn btn-primary card-link"><i class="fa fa-external-link"></i> &nbsp;Plus sur le web</a>



    <a href="/fr/snippets/aleatoire" class="btn btn-primary card-link"><i class="fa fa-dice"></i> &nbsp;Snippet aléatoire</a>
            </p>

            
            

<hr/>

<div class="card-stats">
    <div class="author">
        <a rel="noopener" target="_blank" href="https://twitter.com/C0il">
            <img loading="lazy" src="https://www.strangebuzz.com/media/cache/avatar/img/avatars/coil.jpg" alt="..." class="avatar img-raised">
            <span>par COil</span>
        </a>
    </div>

            <div class="stats ml-auto">
            <div class="blog-tags">
                <a class="badge badge-warning" href="/fr/snippets/tag/symfony"><i class="far fa-tag"></i> &nbsp;Symfony</a> <a class="badge badge-primary" href="/fr/snippets/tag/phpstan"><i class="far fa-tag"></i> &nbsp;phpstan</a> <a class="badge badge-warning" href="/fr/snippets/tag/static-analysis"><i class="far fa-tag"></i> &nbsp;static-analysis</a> <a class="badge badge-primary" href="/fr/snippets/tag/cs"><i class="far fa-tag"></i> &nbsp;cs</a> <a class="badge badge-default" href="/fr/snippets/tag/code-quality"><i class="far fa-tag"></i> &nbsp;code-quality</a> <a class="badge badge-default" href="/fr/snippets/tag/tooling"><i class="far fa-tag"></i> &nbsp;tooling</a>             </div>
                    </div>
    </div>

                <br/>
    <div class="row">
        <div class="col-md-6">
            <p class="card-text h4">
                                                        <i class="fa fa-backward"></i> &nbsp
                    <a href="/fr/snippets/utiliser-l-api-fetch-javascript-de-maniere-asynchrone">Utiliser l&#039;API Fetch JavaScript de manière asynchrone</a>
                            </p>
        </div>

        <div class="col-md-6">
            <p class="card-text h4">
                                                        <a href="/fr/snippets/demander-une-reponse-json-avec-le-client-http-de-test-symfony">Demander une réponse JSON avec le client HTTP de test Symfony
</a> &nbsp;
                    <i class="fa fa-forward"></i>
                            </p>
        </div>
    </div>
        </div>
    </div>
                    </div>

                                    </div>
            </div>
        </div>

        <footer class="footer">
            <div class="container">
                <a class="footer-brand pull-left" href="/fr">
                    <img loading="lazy" alt="Strangebuzz EURL" width="90" src="/img/strangebuzz_1024.png?2.8.0" class=""/>
                </a>

                <div class="copyright pull-center">
                    © Réalisé par <b>COil</b>, &copy; 2007-2021.
                    Propulsé par <a target="_blank" href="https://symfony.com/5">Symfony 5</a>
                    <br/><i class="fab fa-symfony"></i> Symfony ™ est une marque de <a target="_blank" href="https://symfony.com/license">Symfony SAS</a>.
                </div>

                <ul class="social-buttons float-right">
                    <li>
                        <a href="https://feeds.feedburner.com/strangebuzz/fr" target="_blank" class="btn btn-just-icon btn-link">
                            <i class="fas fa-rss-square"></i>
                        </a>
                    </li>

                    <li>
                        <a href="https://tokeeen.com/fr/" target="_blank" class="btn btn-just-icon btn-link">
                            <img loading="lazy" alt="Tokeeen le traceur d&#039;habitudes" src="https://cdn.tokeeen.com/apple-icon-72x72.png" width="25">
                        </a>
                    </li>

                    <li>
                        <a href="https://twitter.com/C0il" target="_blank" class="btn btn-just-icon btn-link btn-twitter">
                            <i class="fab fa-twitter"></i>
                        </a>
                    </li>

                    <li>
                        <a href="https://github.com/COil" target="_blank" class="btn btn-just-icon btn-link btn-github">
                            <i class="fab fa-github"></i>
                        </a>
                    </li>
                </ul>
            </div>
        </footer>
    </div>

            <script src="/vendor/material/js/core/jquery-3.4.1.min.js?2.8.0"></script>
        <script src="/vendor/material/js/core/popper.min.js?2.8.0"></script>
        <script src="/vendor/material/js/bootstrap-material-design.js?2.8.0"></script>
        <script src="/vendor/material/js/material-kit.js?2.8.0"></script>

                    <!-- Global site tag (gtag.js) - Google Analytics -->
            <script async src="https://www.googletagmanager.com/gtag/js?id=UA-26828928-2"></script>
            <script>
                window.dataLayer = window.dataLayer || [];
                function gtag(){dataLayer.push(arguments);}
                gtag('js', new Date());
                gtag('config', 'UA-26828928-2');
            </script>
        
        <!--suppress ES6ConvertVarToLetConst -->
<script>
        const isProd = true;
    const trans = {
        hide_unit_test:  "Cacher les tests unitaires",
        show_unit_test: "Voir les tests unitaires",
        form_error: "Oops! Une erreur est survenue lors de la récépération des suggestions. 😕",
        hide_honey_pot: "Cacher le leurre",
        show_honey_pot: "Montrer le leurre",
        button_collapse_all:  "Réduire tous les logs",
        button_expand_all: "Développer tous les logs",
        hello: "Bonjour Monde !",
        snippet_91_title: "Modification dynamique du titre du document avec Vue.js",
        status_online: "Vous êtes en ligne !",
        status_offline: "Vous êtes hors ligne !",
    };

    const post13 = {
        uri: "",
        success: "false",
        refreshPath: "/fr/blog/13/refresh",
        functions: []
    };

    const post26 = {
        checkPasswordPath: "/fr/blog/26/check-password",
        errorMsg: "Une erreur est survenue en testant le mot de passe désolé. 😕"
    };

            const post138 = {
      login: '',
      password: '',
      errorMsg: "Veuillez entrer un identifiant et un mot de passe."
    };

    var data = typeof data === "undefined" ? {} : data;
</script>

        <script src="/build/runtime.8c994506.js?2.8.0"></script><script src="/build/369.a2139562.js?2.8.0"></script><script src="/build/app.571b4e00.js?2.8.0"></script>
    
    <!-- Generated the 03/11/2021 19:44:09 by srv-PROD with v2.8.0 -->

    </body>
</html>
